Inicio > tecnología > Spotify en ubuntu 9.10

Spotify en ubuntu 9.10

Hace varios meses que os explicaba cómo instalar Spotify en ubuntu mediante wine, y cómo ejecutar los enlaces de Spotify desde Firefox. Tras instalar la última versión de ubuntu (9.10), es posible que hayas encontrado algún problema con la reproducción de música… pareciendo que se queda parada la canción a los pocos segundos de empezar. Todo esto es por el cambio en el gestor de sonido que ahora viene en ubuntu (que deja de ser ALSA y pasa a ser PulseAudio) y la configuración por defecto de wine. Pero no es para alarmarse, con un simple cambio en las propiedades de ejecución todo se resuelve.

……..

Accedemos a la configuración mediante Aplicaciones > Wine > Configure Wine

Deseleccionamos el Manejador ALSA y seleccionamos el Manejador EsounD. Aceptamos y listo; a disfrutar de Spotify.

About these ads
  1. Javier
    1 noviembre 2009 en 13:55

    Hola, muchas gracias por el post, me soluciono el problema…que ya no se vivir sin musica!!!jeje

    lo dicho, gracias

  2. mike
    1 noviembre 2009 en 15:40

    Muchas gracias. Había visto otras páginas con otras soluciones similares pero que no funcionaban. Esta ha ido bien!

  3. 1 noviembre 2009 en 18:16

    A mi también me ha funcionado. Mil gracias.

  4. Samwise
    1 noviembre 2009 en 19:56

    Uff, vaya susto. Era lo único que no funcionaba en 9.10
    Gracias por la solución!!

  5. 1 noviembre 2009 en 20:44

    Gracias a todos por comentar, y me alegro que os haya servido para seguir disfrutando de la música.
    Por cierto ¡¡Espectacular!! el trabajo de los de canonical y beta-testers de ubuntu. Excepto este detalle de configuración por defecto de wine, por todo lo demás… como la seda.

  6. xtban
    2 noviembre 2009 en 18:39

    Muchas gracias por la solución…
    cortita y al pie… como debe ser…

  7. Andrés
    2 noviembre 2009 en 19:17

    Muchas gracias!! Ha funcionado a la perfección.

  8. bigbang
    3 noviembre 2009 en 20:24

    Son cosas de esas tan misteriosas como molestas… hasta que alguien te propone la solución.Muchas gracias!

  9. Efter
    5 noviembre 2009 en 13:29

    Mil gracias, ya no sabía que hacer y ahora me funciona a la perfección!!!!

  10. tororo
    5 noviembre 2009 en 15:19

    Gracias!

  11. Francesc
    6 noviembre 2009 en 14:31

    Espectacular! Ya puedo oir a Fito en Ubuntu con Spotify :-) Muchísimas gracias!!!!

  12. 6 noviembre 2009 en 16:02

    Siempre hay alguien que da una solución a los problemas. Gracias.

  13. Dug
    8 noviembre 2009 en 17:46

    Gracias! Buena solución. Salud!

  14. Alberto
    9 noviembre 2009 en 17:32

    Muchas Gracias!

  15. Juan20150
    12 noviembre 2009 en 20:38

    Ombe!… funcionó a la primera, aunque a mi el sonido con el Alsa si me andaba. Pero, de repente se paraban las canciones, con EsounD parece ir viento y popa, y suena de lo lindo carajo. Gran aporte, saludos ;)

  16. 13 noviembre 2009 en 22:01

    Muchas gracias, como se comenta por arriba, solución fácil, sencilla, y para toda la familia xD Y estoy tambien de acuerdo con vosotros con el gran trabajo que se ha relizado para sacar adelante este ubuntu 9.10 por parte de todos.

    Enviaré la solucion a los conocidos que ya no sabemos vivir sin musica y sin spotify. jaja, un saludo!

  17. helbert hernandez
    16 noviembre 2009 en 21:21

    instale el wine y señale la pesta de audio manjador sounD, reinicio el sistema y no susede nada sigo con el mismo problema tengo sonido en paginas de musica de internet pero en los programas de repruccion como el mplayer nada se ve las pelicula y el sonido por niguna parte y eso que el reproductor de peliculas que biene integrado no muestra ni peliculas ni sonido

    cualquier ayuda gracias

  18. 16 noviembre 2009 en 21:49

    a todos… gracias, muchas gracias por comentar en este pequeño rincón reflejando que os ha servido esta solución para seguir escuchando spotify en ubuntu.

    helbert, lo que comentas es que no puedes reproducir películas ni música en el reproductor del sistema. Para solucionar este problema no es necesario tener instalado wine ni cambiar lo que indico en esta página. ¿cómo arreglarlo? pueden ser muchas cosas, pero prueba lo siguiente.

    No parece que sea problema con el reconocimiento de la tarjeta de sonido (porque escuchas sonidos de la web, según comentas) así que instala los codecs que no vienen por defecto en ubuntu.

    Probablemente necesites añadir librerías extra, por lo que te aconsejo que te añadas el almacén de mediubuntu:

    sudo wget http://www.medibuntu.org/sources.list.d/karmic.list –output-document=/etc/apt/sources.list.d/medibuntu.list
    sudo aptitude update
    sudo aptitude -y –allow-untrusted install medibuntu-keyring
    sudo aptitude update

    y después instala los codecs más utilizados:

    sudo aptitude install ubuntu-restricted-extras
    sudo aptitude install flashplugin-nonfree-extrasound
    sudo aptitude install libdvdcss2
    sudo aptitude install libdvdread4
    sudo aptitude install w32codecs
    sudo aptitude install non-free-codecs

    Si después de esto sigue sin funcionar, habría que ver exactamente el formato que no puedes reproducir. Prueba

  19. elchila
    26 noviembre 2009 en 10:24

    Chachi!!! Funciona de lujo. Gracias!

  20. Jorge
    27 noviembre 2009 en 10:11

    Un 10, sencillo y solución perfecta :D

  21. 26 diciembre 2009 en 18:27

    Muchas gracias por tu aportación. En todos los tutoriales y explicaciones indican a ALSA como gestor del audio en Ubuntu, pero nadie ha caído en actualizar este extremo, y la verdad es que los más profanos en GNU/Linux vamos un poco perdidos en todos estos puntos. De nuevo, muchas gracias por tu ayuda :)

  22. Adrià
    27 diciembre 2009 en 0:22

    Es lo bonito de la comunidad Ubuntu.

    Todos para uno y uno para todos.

    Gracias.

  23. Miguel86
    28 diciembre 2009 en 11:35

    Buenas:
    Yo tengo un 5.1 y nose si es que tiene que ser asi, pero la musica de spotify solo la oigo por el central hay alguna forma de que se oiga por todos? en preferencias de sonido tengo puesto Analog Surround 5.1, si pongo Stereo si oigo por todo, pero claro, lo suyo seria dejar 5.1 para que cuando ponga una pelicula 5.1 se oiga como debe. Se puede hacer algo con eso? recuerdo que en versiones mas antiguas del ubuntu incluso podia usar una entrada de micro como salida de cascos y cosas asi, (como lo que permite hacer el programa de realtek en windows) y ahora ya no veo como hacer eso en esta version de ubuntu, ya no se puede al dejar de usar ALSA?

  24. martini
    18 enero 2010 en 11:42

    Muchas Gràcias!!!!!!!!!!!! :D

  25. tonino
    18 enero 2010 en 14:12

    Es la única solución que me ha funcionado. Gracias

  26. Víctor
    20 enero 2010 en 18:57

    Muchas gracias, esta solución se sale

  27. Revienta
    29 enero 2010 en 16:09

    Si señor. Aporte a priori sencillo pero 100% eficaz.

  28. Pacuman
    22 febrero 2010 en 13:43

    Gracias compi, cada vez me gusta mas ubuntu, tengo el win7 olvidao y mira que es weno, pero esto de que te de problemas y solucionarlo es la lexe! xDD nada nada qeu me quedo en ubuntu, repito gracias y suerte!

  29. 4 marzo 2010 en 16:24

    Gracias, me sirvió.
    Estaba como loco buscando solución a este tema, y era bien simple corregirlo.
    Lo dicho, muchísimas gracias.

  30. marc
    20 marzo 2010 en 17:28

    Buenas!
    He realizado los cambios tal y como se ven en la imagen y el problema persiste: “hay un problema con la tarjeta de sonido. Spotify no puede reproducir música”.
    Hay otras posibles soluciones?

    gracias de antemano!

  31. PABLO
    27 marzo 2010 en 21:21

    Muchas gracias. Ya empezaba a desesperarme, porque me funcionaba cuando le daba la gana. Si no fuera por gente como vosotros…

  32. juan
    1 abril 2010 en 6:15

    hola amigo. primera ve que visito tu blog. y va derechito a mis marcadores. de verdad te doy la thanks ya que me diste la solucion perfecta, habia probado otras cosas pero nada de nada. a cambio con esto si y facil. gracias por ayudar a todas esas personas que emigran a gnu/linux, que cada vez son mas..

  33. gea
    5 abril 2010 en 21:17

    hola
    mi problema es que cuando intento hacer soanr una cancion en spotify emulado con wine en ubuntu 9.10 la reproducción queda congelada, no reproduce nada.
    he provado un monton de soluciones (e incluso la tuya) y ninguna de ellas me funciona

    estoy un poco perdida, se te ocurre que puedo hacer?

    gracias por adelantado :)

  34. eugenia
    13 abril 2010 en 15:28

    me pasa lo mismo que gea

    • 19 abril 2010 en 22:46

      Hola gea, hola eugenia.
      Sí que me lo ponéis difícil, pero vamos a ver qué se puede hacer:
      Mirad si no habéis desinstalado las librerías de pulse-audio > en terminal escribir el comando:

      dpkg -l | grep pulseaudio

      si salen varias líneas, entre ellas “PulseAudio sound server” lo tienes instalado.
      Siguiente comprobación que haría es revisar que tengas la compatibilidad con eSound, con el comando:

      dpkg -l | grep esound

      y te tiene que salir una línea con “pulseaudio-esound-compat”
      Si todo va bien, comprobaría que wine se está comunicando bien con el sistema. Para ello tienes que abrir “Sistema > Preferencias > Sonido” y en la pestaña Aplicaciones comprobar que te aparece la posibilidad de cambiar el volumen de wine (wineesd).

      Si todo te aparece tal cual te he puesto en el comentario… ya no se me ocurre nada. Pero no dudes en decírmelo, que intentamos buscar otra solución

      Un saludo!

  35. Jan
    15 abril 2010 en 14:10

    Cuando instalo esound todo va bien! Pero reinicio y esound desaparece de las opciones de wcfg!!!! Quiero escuchar spotify sin estar super ralentizado!!!!!!!!!!!!!!!!!!!!!! :((((((

    • 19 abril 2010 en 23:10

      Hola Jan.

      Si te interpreto bien, dices que cambias la configuración con winecfg, pero al reiniciar se pierden los cambios. Es raro. No se me ocurre la razón por la que te pueda pasar eso. Intenta bloquear la actualización de los archivos de configuración de wine (.wine/*.reg) después de indicarle los cambios, por ejemplo asociándole el dueño de esos archivos a root y comprueba que siguen igual después de reiniciar.

      La verdad es que no se me ocurre ninguna razón por la que se modifiquen ellos solos, a no ser que tengas algo parecido a playonlinux o crossover… pero tampoco creo que tenga mucho que ver. Lo siento, no se me ocurre nada más.

      Un saludo!!

  36. Lolailaaa
    19 abril 2010 en 2:37

    ¡Muchísimas gracias! Menos mal que he dado con esta página… ¡Gracias!

  37. papo
    28 abril 2010 en 3:56

    hola amigo, tengo una gran pregunta sabes que cuando me instale ubuntu 9.10 tenia problema con el audio, a veces sonoba algunas no, gracias a ti, soluciones mi problema con esound, pero por ciertas circustancia tuve que formatear la raiz, y la volvi a instalar despues de eso, la volvi a instalar nada mas la /, bueno y tuve otra ve el mismo problema y me instale otra ve wine, y hice todo otra ve como ante, pero esta ve no dio resultadooo, esta ve lo cambio a esound y nada, que sera de verdad espero que me puedas ayudar, gracias por tu aportes espero tu respuesta lo pronto posible

  38. 15 junio 2010 en 16:26

    Muchas gracias, eres el único que ha sabido darme una solución a este problema.

  39. carolina
    15 septiembre 2010 en 14:08

    Debo ser un poco pezuñas pero no he sido capaz de encontrar el cuadro de aplicaciones- wine- etc.

    Si fueráis tan amables de hacerme llegar a él…. Graciñas

  40. blnka
    5 agosto 2012 en 2:23

    aayuda!! he instalado spotify, pero no me deja reproducir musica porque me pone “que hay un problema con mi targeta de sonido. que spotify no puede reproducir musica..” he hecho las comprovaciones en terminal que pone mas arriba fsandin todo correcto, pero cuando voy a preferencias de sonido, en aplicaciones no aparece nada….que puedo hacer? muchas gracias!

  41. Raquel
    28 junio 2013 en 13:18

    Holaa, I need help!! A mi en la configuración de wine no me sale lo mismo que a ti en el audio..

  1. 31 octubre 2009 en 19:21
  2. 2 noviembre 2009 en 1:12
  3. 24 enero 2010 en 13:19

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

Únete a otros 52 seguidores

A %d blogueros les gusta esto: